Jump to content
noisebomb44

Command & Conquer generals universal fix thread

Recommended Posts

Posted · Original PosterOP

If you are searching for a fix to run C&C generals and can't find one, ask me here and I'll respond within a few days or so. My aim with this thread is to help as many as possible and try to collect the various fixes for playing this game scattered around the web in one place.

Installer errors

 

"Unable to launch ... datagen.exe" error:

 

"1. Start the installation and wait for the error, abort installation

2. Restart Installation and wait until the installation process requests CD2 (the datagen.exe should be there at this moment)

3. IMPORTANT: Make the datagen.exe write protected (right click the file -> properties)

4. proceed Installation"

(corrected spelling and such in quote)

 

source:

http://answers.ea.com/t5/C-C-The-Ultimate-Collection/Problem-with-Datgen-exe/td-p/330464/page/2

 

 

"1628: Failed to complete installation." error:

 

1.

Do the ""Unable to launch ... datagen.exe" error:" fix untill step 3

 

2.

Copy everything in the folder where datagen.exe is located

 

3.

Finish install

 

4.

Do the ""Unable to launch ... datagen.exe" error:" fix untill step 3 again

 

5.

Overwrite the files inside the folder where the new datagen.exe is located with the files you copied in step 2

 

6.

Finish install, it should work now

 

source:

http://answers.ea.com/t5/C-C-The-Ultimate-Collection/Problem-with-Datgen-exe/td-p/330464/page/2

 

The game doesn't launch after successful install:

It's probably a problem with SafeDisc, you have two choices:

1. Edit your registry (hard way) (doesn't work anymore according to some users)

2. Download a no-cd patch (easier way)

 

In-game errors:

 

 

Technical difficulties error or DirectX error:

 

1.

go to

 

C:\Users\username\Documents\Command and Conquer Generals Data

and or 

C:\Users\username\Documents\Command and Conquer Generals Zero Hour Data

 

2.

 

make an "options.ini" file and paste the following into it:

 

AntiAliasing = 1
CampaignDifficulty = 0
DrawScrollAnchor = 
FirewallBehavior = 1
FirewallNeedToRefresh = FALSE
FirewallPortAllocationDelta = 0
GameSpyIPAddress = 10.0.0.2
Gamma = 50
IPAddress = 10.0.0.2
IdealStaticGameLOD = Low
LanguageFilter = false
MoveScrollAnchor = 
MusicVolume = 0
Resolution = 1024 768
Retaliation = yes
SFX3DVolume = 79
SFXVolume = 71
ScrollFactor = 16
SendDelay = no
StaticGameLOD = High
UseAlternateMouse = no
UseDoubleClickAttackMove = no
VoiceVolume = 70

 

3.

 

Don't worry, you will be able to change those settings later but once you have done this, boot the game and it should work

Patch your game to 1.04 if you want (might also fix other errors?)

 

 

source

 

Misc

Gamedata.ini doesn't excist

Create one in your game directory


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites
Posted · Original PosterOP

a sidenote, if you want to do something cool, set the "MaxParticleCount = 5000" to 999999 or something

something cool might happen, like permanent destruction or something

that is... if your gpu can handle the 2003 graphics


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites

Ah, Zero hour, why did your servers have to be taken from us? Many hours, weeks even of my life vanished with them, nothing to show for all my dedication to giving those pesky workers some shoes.

 

 

Anyway good job, will defo save this article for a later date when I come to play it again.  

Link to post
Share on other sites
Posted · Original PosterOP

Ah, Zero hour, why did your servers have to be taken from us? Many hours, weeks even of my life vanished with them, nothing to show for all my dedication to giving those pesky workers some shoes.

 

 

Anyway good job, will defo save this article for a later date when I come to play it again.  

hah, i remember the zero hour multiplayer, i had like a group of 3 people joining every match i made, just because i had a good internet speed (mighty 200 kb/sec and a ping of 10 - 50)

the multiplayer matches where sometimes epic, and sometimes really booring because people where abusing the scud glitch, which reloaded the scud superweapon like 10 seconds after it was  fired.

and i also remembered when people used strategies, like building hundereds of markets that generates money really fast all the time

 

although if you want it back, i think the "rise of the reds" mods made a internet client which revives multiplayer

 

a demonstreation by someone

https://youtu.be/47gapJfXjaQ?t=1m4s


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites
Posted · Original PosterOP

here is the internet client, named "SWR.net

 

http://moddb.com/mods/rise-of-the-reds/downloads/swrnet-update-1001 (this is the 1.001 update that is requered to play online)

 

it also comes with the "rise of the reds" installer

 

http://moddb.com/mods/rise-of-the-reds/downloads/rise-of-the-reds-version-185


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites

I did try a few mods and private servers after the public servers all went down, so however long ago that was, and there was barely anyone online, and any who was either was in a private room, and the one or two games I did join usually mismatched halfway through.

 

And dam that scud glitch was annoying, I had a full list of cheaters and would check every bugger entering my game, at least near the end of the games life cycle it was the fans playing and not the cheats.

Link to post
Share on other sites

I remember when generals was relatively new, and I used to play it all night long every night.  There was a custom map I'd play that had a canyon that 4 players had to protect from waves of enemies.  You had to create enough turrets to blast them since you were on a cliff and they couldnt pass through the entire canyon or you lost.  Was such a fun game, so many hours wasted.


MOBO- MSI z97 gaming 5  CPU- I5 4690k   GPU- G1 Gaming gtx970  RAM- 16gb Corsair Vegeance  PSU- Corsair RM650  COOLING- Corsair H110iGT 

STORAGE- AMD r7 120gb SSD / 500gb HDD  CASE- Phanteks Enthoo Luxe   Sound-  Logitech z506 / Corsair Void  Peripherals- G710, G502

Link to post
Share on other sites
Posted · Original PosterOP

I did try a few mods and private servers after the public servers all went down, so however long ago that was, and there was barely anyone online, and any who was either was in a private room, and the one or two games I did join usually mismatched halfway through.

And dam that scud glitch was annoying, I had a full list of cheaters and would check every bugger entering my game, at least near the end of the games life cycle it was the fans playing and not the cheats.

I got the game about one year before it went offline, and in the beginning there was a lot of scud abusers, but in the end there was less scud abusers, but the people i met had mastered the game, so i didnt stand a chance most of the time


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites
Posted · Original PosterOP

I remember when generals was relatively new, and I used to play it all night long every night. There was a custom map I'd play that had a canyon that 4 players had to protect from waves of enemies. You had to create enough turrets to blast them since you were on a cliff and they couldnt pass through the entire canyon or you lost. Was such a fun game, so many hours wasted.

I mostly played these kind of maps in the original starcraft, i never knew that people made them for c&c generals


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites

I got the game about one year before it went offline, and in the beginning there was a lot of scud abusers, but in the end there was less scud abusers, but the people i met had mastered the game, so I didn't stand a chance most of the time

 

I played from virtually the release and if you saw it back then it was a mess, cheaters did all sorts from map hacking to money bugging, and not that microwave thingy. They tried to fix the scud bug but it never took hold. Eventually a group of dedicated fans was forced to make GenTool, basically a program that removed the glitch and told other players you were just wanting a honest game.

Link to post
Share on other sites
Posted · Original PosterOP

That doesn't work for me I have an issue where they game starts to run and I get a lack screen for a few seconds and then it crashes

you mean a black screen?

and is the copy legit, and are you using the CD to start the game (aka not using a fixed exe, you have to use the CD the first time, and then add the fixed exe and the dat file)

also, are you using the latest patch (if you have the decade edition, then you have) if not, then try updating it to (C&C generals 1.08, C&C generals zero hour 1.04)

if you have the zero hour expansion, you have to update both to the lastest patch

Do you have directx 9.0 or up

are you using a legit copy of windows 10

does your specs meet the minimun requrements

what kind of error are you getting? (aka if you are getting a error message after the crash, what does it say)


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites

you mean a black screen?

and is the copy legit, and are you using the CD to start the game (aka not using a fixed exe, you have to use the CD the first time, and then add the fixed exe and the dat file)

also, are you using the latest patch (if you have the decade edition, then you have) if not, then try updating it to (C&C generals 1.08, C&C generals zero hour 1.04)

if you have the zero hour expansion, you have to update both to the lastest patch

Do you have directx 9.0 or up

are you using a legit copy of windows 10

does your specs meet the minimun requrements

what kind of error are you getting? (aka if you are getting a error message after the crash, what does it say)

Yes its a legit copy of windows and a legit copy of the game I am using the game CD. 

 

I don't get an error message it just shows a black screen for a couple seconds and then pops me back to the desktop. 

 

How do I download the new patch?

Link to post
Share on other sites
Posted · Original PosterOP

Yes its a legit copy of windows and a legit copy of the game I am using the game CD. 

 

I don't get an error message it just shows a black screen for a couple seconds and then pops me back to the desktop. 

 

How do I download the new patch?

also, it might be worth trying to launch it in administrator mode

and if it doesnt work after all of this, try redoing what i said in the original post, worked for me once because the game sometimes overwrites it after a crash

 

tell me/us if it worked after all of this


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites
Posted · Original PosterOP

the patch

http://cnclabs.com/downloads/generals/patches.aspx

gentool http://gentool.net/

the gentool seems kind of cool, although there are now so many ways to find players to play with, like gameranger, SWR.net, and now gentool

I feel like its splitting the community a bit, although gentool seems to be better than gameranger, with the anticheat and everything, gameranger is just more usefull, since you can join just about any LAN game that doesnt have a online lobby


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites

also, it might be worth trying to launch it in administrator mode

and if it doesnt work after all of this, try redoing what i said in the original post, worked for me once because the game sometimes overwrites it after a crash

 

tell me/us if it worked after all of this

 

 

Still deosn't work after all of this 

 

It worked perfect on windows 8.1

 I'm running as admin and in compatibility modeso I don't know what else to try

Link to post
Share on other sites
Posted · Original PosterOP

Still deosn't work after all of this 

 

It worked perfect on windows 8.1

 I'm running as admin and in compatibility modeso I don't know what else to try

compatibility mode doesnt matter in windows 10 from what ive heard

And, did you install it after installing win 10, aka did you have it installed on win 8, and then when you updated to win 10, did you just keep it and never reinstalled


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites

compatibility mode doesnt matter in windows 10 from what ive heard

And, did you install it after installing win 10, aka did you have it installed on win 8, and then when you updated to win 10, did you just keep it and never reinstalled

 

compatibility mode doesnt matter in windows 10 from what ive heard

And, did you install it after installing win 10, aka did you have it installed on win 8, and then when you updated to win 10, did you just keep it and never reinstalled

 

 

Yes My first reaction was to reinstall so I did that right after updating to windows 10

 

I'll try with compatibility mode off

Link to post
Share on other sites
Posted · Original PosterOP

Nope Didin't work

hmm, ive read some sites, and they say that this problem is caused by not having a legit copy of the game, but i think there is a way to do this.

Try looking into the config after the crash, and see if the resolution is 800 x 600

 

also, you can try to disable AntiAlising, most graphical settings, etc because maybe your graphic card doesnt support them, or maybe it overloads the game

 

If that doesnt work, try to boot the original C&C generals instead of zero hour, maybe that can become a stepping stone

(and if C&C generals doesnt boot, and get the same error, try to redo the step 2 in my original post, or try to use this instead

 

AntiAliasing = 1BuildingOcclusion = yesCampaignDifficulty = 0DynamicLOD = yesExtraAnimations = yesFirewallBehavior = 1FirewallNeedToRefresh = FALSEFirewallPortAllocationDelta = 0GameSpyIPAddress = 0.0.0.0Gamma = 50HeatEffects = yesIPAddress = 0.0.0.0IdealStaticGameLOD = LowLanguageFilter = falseMaxParticleCount = 5000MusicVolume = 68Resolution = 800 600Retaliation = yesSFX3DVolume = 79SFXVolume = 71ScrollFactor = 200SendDelay = noShowSoftWaterEdge = yesShowTrees = yesStaticGameLOD = CustomTextureReduction = 0UseAlternateMouse = yesUseCloudMap = yesUseDoubleClickAttackMove = noUseLightMap = yesUseShadowDecals = yesUseShadowVolumes = yesVoiceVolume = 70

Also, what resolution does your monitor have?

And is it a laptop, with two graphic cards, (aka a CPU with a Nvidia or AMD graphic card in it, it should say so on the stickers under the keyboard)

if so, rightclick the game (original c&c generals) and try to first use the integrated graphic card to run the game, and then try the dedicated graphic card (aka nvidia / AMD)


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites

 

hmm, ive read some sites, and they say that this problem is caused by not having a legit copy of the game, but i think there is a way to do this.

Try looking into the config after the crash, and see if the resolution is 800 x 600

 

also, you can try to disable AntiAlising, most graphical settings, etc because maybe your graphic card doesnt support them, or maybe it overloads the game

 

If that doesnt work, try to boot the original C&C generals instead of zero hour, maybe that can become a stepping stone

(and if C&C generals doesnt boot, and get the same error, try to redo the step 2 in my original post, or try to use this instead

 

AntiAliasing = 1BuildingOcclusion = yesCampaignDifficulty = 0DynamicLOD = yesExtraAnimations = yesFirewallBehavior = 1FirewallNeedToRefresh = FALSEFirewallPortAllocationDelta = 0GameSpyIPAddress = 0.0.0.0Gamma = 50HeatEffects = yesIPAddress = 0.0.0.0IdealStaticGameLOD = LowLanguageFilter = falseMaxParticleCount = 5000MusicVolume = 68Resolution = 800 600Retaliation = yesSFX3DVolume = 79SFXVolume = 71ScrollFactor = 200SendDelay = noShowSoftWaterEdge = yesShowTrees = yesStaticGameLOD = CustomTextureReduction = 0UseAlternateMouse = yesUseCloudMap = yesUseDoubleClickAttackMove = noUseLightMap = yesUseShadowDecals = yesUseShadowVolumes = yesVoiceVolume = 70

Also, what resolution does your monitor have?

And is it a laptop, with two graphic cards, (aka a CPU with a Nvidia or AMD graphic card in it, it should say so on the stickers under the keyboard)

if so, rightclick the game (original c&c generals) and try to first use the integrated graphic card to run the game, and then try the dedicated graphic card (aka nvidia / AMD)

 

My stuff supports it because I used it on windows 8.1 it stopped working when I upgraded. 

 

My monitor is 1650x1050

 

My PC is a desktop with AMD CPU and GPU 

 

And I'm rtrying to run the original generals I wasn't a big fan of Zero Hour

Link to post
Share on other sites
Posted · Original PosterOP

try to see if you can run zero hour then, maybe it will work

also

did you try to do the things i mentioned in my last post?


Long live Stalin, he loves you; sing these words, or you know what he’ll do!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Sign in

Already have an account? Sign in here.



  • Recently Browsing 0 members

    No registered users viewing this page.

Last Topics

lol pvp net patcher kernel is not responding install xbox 360 controller windows 7 icloud outlook calendar sync asus bios reset jumper window 7 this copy is not genuine windows 7 not genuine 7601 how do i get contacts from icloud mbs in a gig windows 7 is not genuine build 7601 fix asus laptop restore to factory unifi ap outdoor default ip drill bit to remove stripped screw office 365 contacts sync headphone jack converter 3.5 to 2.5 crack for command and conquer generals zero hour darksiders worm puzzle 8gb hard drive for xbox 360 how to sync contacts in icloud dd wrt linksys ea2700 xbox 360 wired gamepad how to reset your bios password how many megs in a gb external hard drive for xbox 360 elite command and conquer generals zero hour patch 1.04 launch ica error in citrix where can i get super rod in pokemon emerald latest version of citrix receiver pvp.net kernel has stopped working ubiquiti wireless controller windows 8 bios password ubiquiti unifi setup pokemon emerald 368 sao season 2 english dub


×